Networking issues impacting Azure Services in West US

Incident Report for Alkira Inc

Resolved

Update from Azure:
Between 14:40 UTC and as early as 18:26 UTC on 23 July 2026, customers may have experienced intermittent connectivity failures, increased latency, or difficulty accessing Azure and other Microsoft cloud ( https://status.cloud.microsoft/ ) services associated with the West US region. Customers whose traffic traversed affected West US network infrastructure may also experience downstream impact. Customers leveraging affected downstream Azure services may have experienced a long tail of impact as individual services implemented and monitored service recovery measures. This issue is now resolved.
Posted Jul 23, 2026 - 20:42 UTC

Monitoring

Update from Azure:
We identified a recent change that was strongly correlated with the onset of impact and have initiated rollback actions. The rollback is currently in progress and making steady progress toward completion. Telemetry across services is beginning to show signs of recovery.

We are closely monitoring service health and traffic recovery as these actions are completed and will provide additional updates as we confirm measurable improvement.
Posted Jul 23, 2026 - 19:40 UTC

Identified

Azure has reported having networking infrastructure issues in West US. While the issue does not impact existing network status, we are posting this here so our customers are aware. New provisions might fail in the West US region. Alkira's services are not impacted during this time due to active redundancy.

https://azure.status.microsoft/en-us/status#

Summary of Impact from Azure - We are investigating a networking issue affecting connectivity to Azure services in the West US region. Impacted customers may experience intermittent connectivity failures, increased latency, or difficulty accessing Azure services. Customers with traffic traversing the West US region may also experience downstream impact.

We are exploring mitigation options on affected network devices. Early indications suggest the issue is related to network traffic flow through the impacted infrastructure; however our analysis remains ongoing. We are closely monitoring traffic while continuing our investigation.
Posted Jul 23, 2026 - 16:57 UTC
This incident affected: CXP Regions - Americas (USWEST-AZURE-1 (California)).