Issues with AWS services in the ME-CENTRAL-1 Region

Incident Report for Alkira Inc

Update

AWS started seeing increased API error rates in ME-SOUTH-1 Region from Mar 01 9:56 PM PST. Current issues are affecting both ME-SOUTH-1 and ME-CENTRAL-1. Recovery is expected to take at least a day due to required facility, power, and safety assessments. For more details: https://health.aws.amazon.com/health/status
Posted Mar 02, 2026 - 17:11 UTC

Update

AWS continues to work on restoring services. Recovery is expected to take at least a day due to required facility, power, and safety assessments. For more details: https://health.aws.amazon.com/health/status
Posted Mar 02, 2026 - 17:06 UTC

Update

AWS continues to work on restoring services. For more details: https://health.aws.amazon.com/health/status
Posted Mar 01, 2026 - 20:25 UTC

Identified

Update from AWS:
A localized power outage is impacting one Availability Zone (mec1-az2) in the ME-CENTRAL-1 region. As a result, EC2 instances, databases, EBS volumes, and other resources in that zone are unavailable or experiencing connectivity issues. Some AWS services are also seeing increased errors and latency. For more details: https://health.aws.amazon.com/health/status
Posted Mar 01, 2026 - 15:05 UTC

Update

We are continuing to investigate this issue.
Posted Mar 01, 2026 - 14:24 UTC

Investigating

AWS is investigating issues with AWS services in the ME-CENTRAL-1 Region. Issue is related to connectivity and power affecting APIs and instances in a single Availability Zone (mec1-az2) in the ME-CENTRAL-1 Region due to a localized power issue. Issue started at Mar 01 4:51 AM PST. For more details: https://health.aws.amazon.com/health/status
Posted Mar 01, 2026 - 14:23 UTC
This incident affects: CXP Regions - EMEA (ME-CENTRAL-1 (UAE), ME-SOUTH-1 (Bahrain)).